プロジェクト

全般

プロフィール

丼鯖を全文検索へ対応 » 履歴 » バージョン 1

白林檎 美和, 2020/07/15 02:53

1 1 白林檎 美和
# 丼鯖を全文検索へ対応
2
## 材料
3
* FreeBSD上で稼働する丼鯖
4
5
## ElasticSearchのインスコ
6
1. 導入済みのportsを更新。
7
8
    ```
9
# portsnap fetch update
10
# portupgrade -a
11
```
12
1. textproc/elasticsearch6をインスコ。最新版は7だが,**丼では使えない**。
13
    ```
14
# make -C /usr/ports/textproc/elasticsearch6 config-recursive install clean
15
```
16
1. データ置き場を分けた方は, /usr/local/etc/elasticsearch/elasticsearch.yml の `path.data` を変更。
17
    ```
18
path.data: /usr/home/elasticsearch
19
```
20
1. /etc/rc.conf へ `elasticsearch_enable="YES"` を追加。
21
1. ElasticSearchを起動。
22
    ```
23
# service elasticsearch start
24
```
25
26
## 丼鯖の設定変更
27
1. ~/live/.env.production へ次を追加。
28
29
    ```
30
ES_ENABLED=true
31
ES_HOST=localhost
32
ES_PORT=9200
33
```
34
1. 索引を作成。
35
    ```
36
$ bundle exec rake chewy:upgrade
37
```
38
1. 丼サービスを再起動。
39
    ```
40
# service mastodon restart
41
```