プロジェクト

全般

プロフィール

丼鯖を全文検索へ対応 » 履歴 » バージョン 3

白林檎 美和, 2021/10/09 01:11

1 1 白林檎 美和
# 丼鯖を全文検索へ対応
2
## 材料
3
* FreeBSD上で稼働する丼鯖
4
5
## ElasticSearchのインスコ
6
1. 導入済みのportsを更新。
7
8
    ```
9
# portsnap fetch update
10
# portupgrade -a
11
```
12 3 白林檎 美和
1. textproc/elasticsearch7をインスコ。
13 1 白林檎 美和
    ```
14 3 白林檎 美和
# make -C /usr/ports/textproc/elasticsearch7 config-recursive install clean
15 1 白林檎 美和
```
16
1. データ置き場を分けた方は, /usr/local/etc/elasticsearch/elasticsearch.yml の `path.data` を変更。
17
    ```
18
path.data: /usr/home/elasticsearch
19
```
20
1. /etc/rc.conf へ `elasticsearch_enable="YES"` を追加。
21
1. ElasticSearchを起動。
22
    ```
23
# service elasticsearch start
24
```
25
26
## 丼鯖の設定変更
27
1. ~/live/.env.production へ次を追加。
28
29
    ```
30
ES_ENABLED=true
31
ES_HOST=localhost
32
ES_PORT=9200
33
```
34
1. 索引を作成。
35
    ```
36 3 白林檎 美和
$ export RAILS_ENV=production
37 1 白林檎 美和
$ bundle exec rake chewy:upgrade
38
```
39 2 白林檎 美和
1. /usr/local/etc/rc.d/mastodon の `# REQUIRE:` へ, `elasticsearch` を追加。
40
    ```
41
# REQUIRE: nginx postgresql redis elasticsearch
42
```
43 1 白林檎 美和
1. 丼サービスを再起動。
44
    ```
45
# service mastodon restart
46
```